NOTICE: This website will be shut down in the near future. Product content has moved to nxp.com. Forum content and FAQs have been moved to community.nxp.com. We encourage you to create a user account on nxp.com to use the new community forums and access NXP microcontroller content. We greatly appreciate your contributions and look forward to seeing you at our new web location.

 

CMSIS-DAP debug connection gives "RedlinkAPI: Unsupported with current settings" error

lpcxpresso-support's picture

When connecting from the LPCXpresso IDE to a CMSIS-DAP enabled debug probe, if you encounter the following message:

Error: Unable to connect wire for probe index 1.
RedlinkAPI: Unsupported with current settings

Redlink Server will be restarted.
Please restart your debug session.
Exception

the most likely reason is that you are trying to connect to the target MCU using JTAG rather than SWD (as the current support for CMSIS-DAP in LPCXpresso does not support JTAG).

Note that in LPCXpresso 6.0.4 and later, you should see an error message similar to the following in such circumstances…

Use of JTAG with 'Keil ULINK-ME CMSIS-DAP' is not currently supported.
Reconfigure the Launch Configuration to use an SWD connection instead.

For most MCU's SWD is the default connection mechanism so this error will not be seen unless you have changed the debug connection settings. However for LPC43xx family parts the default connection is via JTAG. Thus if you see this message, the solution is to ensure that you modify your launch configuration to use SWD. For more details please see the "Launch Configuration Menu" FAQ.

Note that this means that using a CMSIS-DAP enabled probe it is only possible to debug the Cortex-M4 CPU within the LPC43xx, and not the Cortex-M0 (which cannot be connected to through SWD).

0
Your rating: None
feedback