NOTICE: This website will be shut down in the near future. Product content has moved to nxp.com. Forum content and FAQs have been moved to community.nxp.com. We encourage you to create a user account on nxp.com to use the new community forums and access NXP microcontroller content. We greatly appreciate your contributions and look forward to seeing you at our new web location.

 

Using Version Control within the IDE

lpcxpresso-support's picture

Version control systems for use with LPCXpresso IDE are available throught the Eclipse plugin mechanism.

Many such plugins are available through the Eclipse Marketplace plugin. For more information on installing Marketplace, visit EclipseMarketplace. When selecting which Marketplace plugin to install, for LPCXpresso 6 use the Eclipse Indigo update site.

The rest of the FAQ looks at some commonly used version control plugins.

 

CVS


The tools ship with a built-in client for the Concurrent Versions System (CVS). With this client you can access CVS repositories.

You can find more information on CVS at: http://ximbiot.com/cvs/

You can also visit the Eclipse CVS FAQ.

 

Subversion (SVN)


For use with Subversion repositories, there is a choice of two plugins - Subclipse and Subversive.

More information on Subversion at: http://subversion.apache.org/

Subclipse

Subclipse is a great client for using with a Subversion repository and is the client used by the LPCXpresso IDE development team.

For more information on Subclipse, see: http://subclipse.tigris.org/

There is a choice of Subclipse clients to connect to different versions of Subclipse repositories. All of the available clients can be found here:

http://subclipse.tigris.org/servlets/ProjectProcess?pageID=p4wYuA

To install the latest Subclipse 1.10 client:

  • Select Help->Install new software
  • Press Add...
  • Enter:
    • Subclipse in the the Name field and
      • Note this Location was current at the time of writing (Jan 2014), but may have been changed. Follow the link to check if it is still current.
  • Press OK
  • Check everything except Subclipse Integration for Mylin (optional) (see below for additional information).
    • Mac OSX users should see the additional notes below
  • Press Next
  • Press Next
  • Accept the license and press Finish
 
Notes on installing Subclipse on Mac OSX
 
On Mac OSX, unless you have an up-to-date JavaHL client, you will need to:
  • Follow the instructions above for installing Subclipse, and ensure the SVNKit Client Adapter (in the Subclipse group) is selected for installation.
  • After restarting the IDE, you will need to edit a preference to use the SVNKit Client adapter, by:
    • Open the IDE preferences
    • Expand Team and click on SVN
      • This will open a "Subversion Native Library Not Available" dialog. Hit Cancel
    • Under SVN Interface, select SVNKit (Pure Java) and press OK
  • Subclipse can now be used within the IDE
 
Important note on installing Subclipse
 
The complete installation of Subclipse includes an optional component Subclipse Integration for Mylin that requires a component of Eclipse that is not provided in the product. For the installation to proceed correctly, this entry MUST be unchecked.
 

Subversive


Information on the Subversive plugin can be found at:
The update site for Subversive can be found at:
Installation instructions can be found at:
 

Git


Information on the Eclipse Git plugin (Egit) can be found at: http://www.eclipse.org/egit/
 
It has been reported that creating a repository or accessing Window/Preferences/Team/Git/Configuration hangs LPCXpresso IDE. A solution for this is to append to the following line to the lpcxpresso.ini file:
 
-Djgit.gitprefix=C:/path/to/Git/etc
 
Remember to replace C:/path/to/Git/etc with your local Git installation path.
 

TFS - Team Foundation Server


Microsoft produce an offical Eclipse plugin for TFS. For more details, see:

 

 

 

0
Your rating: None
feedback