NOTICE: This website will be shut down in the near future. Product content has moved to nxp.com. Forum content and FAQs have been moved to community.nxp.com. We encourage you to create a user account on nxp.com to use the new community forums and access NXP microcontroller content. We greatly appreciate your contributions and look forward to seeing you at our new web location.

 

Power measurement tool and internal web browser unavailable

2 replies [Last post]
filartrix
Offline
Joined: 2015-05-18
Posts: 17

I've installed LPCXpresso 7.8.o for Linux 64 bit, on Ubuntu 14.04
My problem is related to the internal web Browser, which is not available.
As result I cannot use the power Measurement Tool.
I have other version of eclipse installed on my system, even CDT based on Eclipse Luna 4.4.2 and on all of them the internal web browser works.
Does anyone has the same Issue?
Can I use the Power Measurement Tool on my custom version of eclipse?
Thanks

Internal Browser not avaliable
Screenshot - 05062015 - 12:28:36.png
0
Your rating: None

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
lpcxpresso-support's picture
lpcxpresso-support
Offline
Joined: 2013-06-06
Posts: 2659

Hi Filippo,

I've been able to replicate your issue here. I suspect that the difference between the LPCXpresso 7.8.0 and the Eclipse Luna 4.4.2 you have installed is that LPCXpresso is a 32-bit install.

To get the internal web browser working you'll need to install libwebkitgtk-1.0-0 It takes a bit of hacking to get this done but I was eventually able to get it going.

I tried this on a clean Ubuntu Desktop 14.04.2 install in a VM. Please read through the whole process and understand it before attempting this hack. It may have unintended side effects, so be sure to have your system backed up. Proceed at your own risk. Having said that it seems to work fine on my machine.

So the problem I saw was:

sudo apt-get install  libwebkitgtk-1.0-0:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libwebkitgtk-1.0-0:i386 : Depends: libenchant1c2a:i386 (>= 1.6.0) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Trying to apt-get libenchant1c2a also fails with something like:

dpkg: dependency problems prevent configuration of libenchant1c2a:
 libenchant1c2a depends on aspell-en | myspell-dictionary | aspell-dictionary | ispell-dictionary | hunspell-dictionary.
 libenchant1c2a depends on libaspell15 (>= 0.60.7~20110707).

I went and downloaded the corresponding libenchant1c2a_1.6.0-10ubuntu1_i386.deb deb file for the 32-bit version and saved it to my desktop.

I downloaded a script called debcontroledit from here to edit the deb control file (the file with the package dependencies and so on).

I opened the control file with the script:

sudo debcontroledit libenchant1c2a_1.6.0-10ubuntu1_i386.deb

I changed the Multi-Arch: same to Multi-Arch: foreign and deleted the following dependencies:

aspell-en | myspell-dictionary | aspell-dictionary | ispell-dictionary | hunspell-dictionary,  libaspell15

I saved the changes and quit the editor. The debcontroledit saved a new copy called libenchant1c2a_1.6.0-10ubuntu1_i386.modfied.deb, which I installed using:

sudo dpkg -i libenchant1c2a_1.6.0-10ubuntu1_i386.modfied.deb

It should install ok now, but if you see any messages about other missing dependencies just run:

sudo apt-get -f install

Next you can install the 32-bit libwebkitgtk-1.0-0:

sudo apt-get install libwebkitgtk-1.0-0:386

and finally when you launch LPCXpresso you'll hopefully be able to use the Power Tool. (Note that this also applies to the graphical view of the interrupt traces).

---
** Latest version of LPCXpresso IDE : v8.1.4 **
http://www.lpcware.com/content/forum/lpcxpresso-latest-release

Visit the LPCXpresso FAQs at http://www.lpcware.com/faq/lpcxpresso

---
** Latest version of LPCXpresso IDE : v8.1.4 **
http://www.lpcware.com/content/forum/lpcxpresso-latest-release

Visit the LPCXpresso FAQs at http://www.lpcware.com/faq/lpcxpresso

filartrix
Offline
Joined: 2015-05-18
Posts: 17

Thank you very much for your answer.
I had to play a bit with packages but it solved the issue.
Filippo

feedback